re = /^@import\s+(?:url\(['"]?.*?['"]?\)|['"].*?['"])(\s+[^;]+?)?;$/im
str = '@import url(https://clearvision.github.io/ClearVision-v6/main.css) asd;
@import url("https://clearvision.github.io/ClearVision-v6/main.css") asd;
@import \'https://clearvision.github.io/ClearVision-v6/main.css\' asd;
@import url("landscape.css") screen and (orientation: landscape);
@import "landscape.css" screen and (orientation: landscape);
@import url("flexy.css") supports(not (display: grid) and (display: flex)) screen
and (max-width: 400px);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end