// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)^@import\s+(?:url\(['"]?.*?['"]?\)|['"].*?['"])(\s+[^;]+?)?;$"#).unwrap();
let string = "@import url(https://clearvision.github.io/ClearVision-v6/main.css) asd;
@import url(\"https://clearvision.github.io/ClearVision-v6/main.css\") asd;
@import 'https://clearvision.github.io/ClearVision-v6/main.css' asd;
@import url(\"landscape.css\") screen and (orientation: landscape);
@import \"landscape.css\" screen and (orientation: landscape);
@import url(\"flexy.css\") supports(not (display: grid) and (display: flex)) screen
and (max-width: 400px);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}