#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(WT|PBMC)\-\d{5,6}"
Local $sString = "These should work:" & @CRLF & _
"PBMC-12345" & @CRLF & _
"WT-234293" & @CRLF & _
"" & @CRLF & _
"These should not work:" & @CRLF & _
"PBMC1234" & @CRLF & _
"WT12345" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")