$re = '/(WT|PBMC)\-\d{5,6}/m';
$str = 'These should work:
PBMC-12345
WT-234293
These should not work:
PBMC1234
WT12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);