import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(WT|PBMC)\\-\\d{5,6}";
final String string = "These should work:\n"
+ "PBMC-12345\n"
+ "WT-234293\n\n"
+ "These should not work:\n"
+ "PBMC1234\n"
+ "WT12345\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}