# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+?) +f\((.+?)\)= *(.+)/\1 = \2(\1, \3)/gm;t' <<< "local r f(table.foreach)= print"