using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+?) +f\((.+?)\)= *(.+)";
string substitution = @"\1 = \2(\1, \3)";
string input = @"local r f(table.foreach)= print";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}