import Foundation
let pattern = #"(\w+?) +f\((.+?)\)= *(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"local r f(table.foreach)= print"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 = \2(\1, \3)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)