# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=[^,]*$)/, or/;t' <<< "item1, item2, item3"