$re = '/,(?=[^,]*$)/';
$str = 'item1, item2, item3';
$subst = ", or";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;