use strict;
my $str = 'item1, item2, item3';
my $regex = qr/,(?=[^,]*$)/p;
my $subst = ', or';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";