import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?City:\\s*(.*?)(?=\\s*(?:Name:|Address:|City:|$))";
final String string = "Name: John Doe Address: Street 123 ABC \n"
+ "Name: John Doe Address: Street 123 ABC City: MyCity\n"
+ "Name: John Doe City: MyCity Address: Street 123 ABC \n"
+ "Some other textName: John Doe Address: Street 123 ABC City: MyCity\n"
+ "Name: John Doe Address: Street 123 ABC City: MyCity Address: Second address\n"
+ "Name: John DoeAddress: Street 123 ABC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}