import re
regex = re.compile(r"^.*?City:\s*(.*?)(?=\s*(?:Name:|Address:|City:|$))", flags=re.MULTILINE)
test_str = ("Name: John Doe Address: Street 123 ABC \n"
"Name: John Doe Address: Street 123 ABC City: MyCity\n"
"Name: John Doe City: MyCity Address: Street 123 ABC \n"
"Some other textName: John Doe Address: Street 123 ABC City: MyCity\n"
"Name: John Doe Address: Street 123 ABC City: MyCity Address: Second address\n"
"Name: John DoeAddress: Street 123 ABC")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")