$re = '/^https:\/\/(?!quora.com*)\S+\/*/m';
$str = 'https://questionsmilitaires.quora.com/?share=1
https://quorafr.quora.com/
https://quora.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);