re = /^https:\/\/(?!quora.com*)\S+\/*/m
str = 'https://questionsmilitaires.quora.com/?share=1
https://quorafr.quora.com/
https://quora.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end