import re
regex = re.compile(r"^https:\/\/(?!quora.com*)\S+\/*", flags=re.MULTILINE)
test_str = ("https://questionsmilitaires.quora.com/?share=1\n"
"https://quorafr.quora.com/\n\n"
"https://quora.com/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")