$re = '/\/((?:[^\/]*\/){2})[^\/]*/';
$str = '/this/is/some/url';
$subst = "$1a";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;