import re
regex = re.compile(r"\/((?:[^\/]*\/){2})[^\/]*")
test_str = "/this/is/some/url"
subst = "$1a"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)