re = /\/((?:[^\/]*\/){2})[^\/]*/
str = '/this/is/some/url'
subst = '$1a'
result = str.sub(re, subst)
# Print the result of the substitution
puts result