using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d.]+)\s?(\D{0,2})\s?x\s?([\d.]+)\s?\2?|(\d+)";
string input = @"Canvas 36.5 X 48 piece-10
wallpaper 3""X27""
Banner 49x87 -10
14 Vinyl 38 x 9.7
wallpaper 3ftX2Ft PC-1";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}