use strict;
my $str = 'Canvas 36.5 X 48 piece-10
wallpaper 3"X27"
Banner 49x87 -10
14 Vinyl 38 x 9.7
wallpaper 3ftX2Ft PC-1';
my $regex = qr/([\d.]+)\s?(\D{0,2})\s?x\s?([\d.]+)\s?\2?|(\d+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}