#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+( |\d+|bte|-|boite|[\w] {1}|([a-z] ){1}){0,2}"
Local $sString = "rue hovémont 3" & @CRLF & _
"rue hovémont 3-5" & @CRLF & _
"rue hovémont 3 5" & @CRLF & _
"Rue hovémont 35" & @CRLF & _
"Rue hovémont 46 A" & @CRLF & _
"Rue hovémont 46 A1" & @CRLF & _
"46 A1 Rue hovémont " & @CRLF & _
"46 A Rue hovémont " & @CRLF & _
"Rue du pont de pierre, 1" & @CRLF & _
"Chaussée d alseg 416 c" & @CRLF & _
"Chaussée d alseg, 416 c" & @CRLF & _
"Chaussée d alseg 416c" & @CRLF & _
"Chaussée d alseg, 416c" & @CRLF & _
"416 c Chaussée d alseg" & @CRLF & _
"416 c, Chaussée d alseg" & @CRLF & _
"416c Chaussée d alseg" & @CRLF & _
"416c, Chaussée d alseg" & @CRLF & _
"Square de la demi-lune 7 boite 5" & @CRLF & _
"7 boite 5 Square de la demi-lune " & @CRLF & _
"Rue aux laines 150/58" & @CRLF & _
"Rue de la forêt, 95" & @CRLF & _
"Chaussée d'anvers 294" & @CRLF & _
"Avenue jean sébastien bach, 24 bte 32" & @CRLF & _
"10 bte 1 rue des volontaires" & @CRLF & _
"Rue du 5ème Tïme 5 bte 2" & @CRLF & _
"Rue du 5eme Tïme 5 bte 2" & @CRLF & _
"20a Test Strasse"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")