using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+( |\d+|bte|-|boite|[\w] {1}|([a-z] ){1}){0,2}";
string input = @"rue hovémont 3
rue hovémont 3-5
rue hovémont 3 5
Rue hovémont 35
Rue hovémont 46 A
Rue hovémont 46 A1
46 A1 Rue hovémont
46 A Rue hovémont
Rue du pont de pierre, 1
Chaussée d alseg 416 c
Chaussée d alseg, 416 c
Chaussée d alseg 416c
Chaussée d alseg, 416c
416 c Chaussée d alseg
416 c, Chaussée d alseg
416c Chaussée d alseg
416c, Chaussée d alseg
Square de la demi-lune 7 boite 5
7 boite 5 Square de la demi-lune
Rue aux laines 150/58
Rue de la forêt, 95
Chaussée d'anvers 294
Avenue jean sébastien bach, 24 bte 32
10 bte 1 rue des volontaires
Rue du 5ème Tïme 5 bte 2
Rue du 5eme Tïme 5 bte 2
20a Test Strasse";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}