import re
regex = re.compile(r"\d+( |\d+|bte|-|boite|[\w] {1}|([a-z] ){1}){0,2}", flags=re.MULTILINE)
test_str = ("rue hovémont 3\n"
"rue hovémont 3-5\n"
"rue hovémont 3 5\n"
"Rue hovémont 35\n"
"Rue hovémont 46 A\n"
"Rue hovémont 46 A1\n"
"46 A1 Rue hovémont \n"
"46 A Rue hovémont \n"
"Rue du pont de pierre, 1\n"
"Chaussée d alseg 416 c\n"
"Chaussée d alseg, 416 c\n"
"Chaussée d alseg 416c\n"
"Chaussée d alseg, 416c\n"
"416 c Chaussée d alseg\n"
"416 c, Chaussée d alseg\n"
"416c Chaussée d alseg\n"
"416c, Chaussée d alseg\n"
"Square de la demi-lune 7 boite 5\n"
"7 boite 5 Square de la demi-lune \n"
"Rue aux laines 150/58\n"
"Rue de la forêt, 95\n"
"Chaussée d'anvers 294\n"
"Avenue jean sébastien bach, 24 bte 32\n"
"10 bte 1 rue des volontaires\n"
"Rue du 5ème Tïme 5 bte 2\n"
"Rue du 5eme Tïme 5 bte 2\n"
"20a Test Strasse")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")