#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<timestamp>[0-9:\.\- ]+)\s+\[[^\]]+\]\s+\[(?P<thread>\d+)\]\s+\[(?P<level>\w+)\]\s+(?P<message>.*)$"
Local $sString = "2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [320] [INFO] Booting worker with pid: 320" & @CRLF & _
"2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [319] [INFO] Booting worker with pid: 319" & @CRLF & _
"2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [318] [INFO] Booting worker with pid: 318" & @CRLF & _
"2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [317] [INFO] Booting worker with pid: 317" & @CRLF & _
"2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [316] [INFO] Booting worker with pid: 316"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")