using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<timestamp>[0-9:\.\- ]+)\s+\[[^\]]+\]\s+\[(?P<thread>\d+)\]\s+\[(?P<level>\w+)\]\s+(?P<message>.*)$";
string input = @"2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [320] [INFO] Booting worker with pid: 320
2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [319] [INFO] Booting worker with pid: 319
2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [318] [INFO] Booting worker with pid: 318
2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [317] [INFO] Booting worker with pid: 317
2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [316] [INFO] Booting worker with pid: 316";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}