const regex = new RegExp('^(?P<timestamp>[0-9:\\.\\- ]+)\\s+\\[[^\\]]+\\]\\s+\\[(?P<thread>\\d+)\\]\\s+\\[(?P<level>\\w+)\\]\\s+(?P<message>.*)$', 'gm')
const str = `2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [320] [INFO] Booting worker with pid: 320
2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [319] [INFO] Booting worker with pid: 319
2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [318] [INFO] Booting worker with pid: 318
2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [317] [INFO] Booting worker with pid: 317
2024-01-31 12:38:52.485 [2024-01-31 17:38:47 +0000] [316] [INFO] Booting worker with pid: 316`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}