using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!\bDBA\b|\bdba\b|\bDbA\b|\bdBa\b|\bDBa\b|\bdBA\b)[a-zA-Z0-9"" ""\-\&]*$";
string input = @"exclude word DBA from string";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}