$re = '/\b(?!\bDBA\b|\bdba\b|\bDbA\b|\bdBa\b|\bDBa\b|\bdBA\b)[a-zA-Z0-9" "\-\&]*$/';
$str = 'exclude word DBA from string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);