re = /\b(?!\bDBA\b|\bdba\b|\bDbA\b|\bdBa\b|\bDBa\b|\bdBA\b)[a-zA-Z0-9" "\-\&]*$/
str = 'exclude word DBA from string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end