import re
regex = re.compile(r"""
^(?:(http?|s?ftp):\/\/|file:\/\/\/)?(([\P{Cc}]+):([\P{Cc}]+)@)?([a-zA-Z0-9][a-zA-Z0-9.-]*)(:[0-9]{1,5})?($|\/[\w\-\._~:\/?[\]@!\$&'\(\)\*\+,;=.]+(\#[\w]*)?$)
""", flags=re.IGNORECASE | re.VERBOSE | re.MULTILINE)
test_str = ("sftp://monitoring.fre31/nagios/cgi-bin/status.cgi?hostgroup=fezgz&style=detail\n"
"file:///opt/myfile.tar.gz\n"
"https://test:ho@mydomain/video.mp4\n"
"https://test:ho@mydomain.frho.fr/fhi/subdir/download#jfpze")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")