// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ixm)^(?:(http?|s?ftp):\/\/|file:\/\/\/)?(([\P{Cc}]+):([\P{Cc}]+)@)?([a-zA-Z0-9][a-zA-Z0-9.-]*)(:[0-9]{1,5})?($|\/[\w\-\._~:\/?[\]@!\$&'\(\)\*\+,;=.]+(\#[\w]*)?$)").unwrap();
let string = "sftp://monitoring.fre31/nagios/cgi-bin/status.cgi?hostgroup=fezgz&style=detail
file:///opt/myfile.tar.gz
https://test:ho@mydomain/video.mp4
https://test:ho@mydomain.frho.fr/fhi/subdir/download#jfpze";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}