package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a [^>]* href=['\"]([^'\"]+)['\"][^>]*>)`)
var str = `<a href="http://dailymail.co.uk">DailyMail</a>
<a href="about.html">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}