re = /(<a [^>]* href=['\"]([^'\"]+)['\"][^>]*>)/x
str = '<a href="http://dailymail.co.uk">DailyMail</a>
<a href="about.html">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end