$re = '/(<a [^>]* href=[\'\"]([^\'\"]+)[\'\"][^>]*>)/x';
$str = '<a href="http://dailymail.co.uk">DailyMail</a>
<a href="about.html">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);