using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(:[0-9]*)$";
string input = @"00:Compression terminée:9782700257205.datas.binary:9935108
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}