$re = '/(:[0-9]*)$/m';
$str = '00:Compression terminée:9782700257205.datas.binary:9935108
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);