re = /(:[0-9]*)$/m
str = '00:Compression terminée:9782700257205.datas.binary:9935108
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end