using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(.*?(?<!\\))'|\s+";
string input = @"Hello 'how\\'re you feeling' foo bar abc 'Strings are cool' d b s ;12gh gh76;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}