re = /'(.*?(?<!\\))'|\s+/
str = 'Hello \'how\\\\\'re you feeling\' foo bar abc \'Strings are cool\' d b s ;12gh gh76;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end