use strict;
my $str = 'Hello \'how\\\\\'re you feeling\' foo bar abc \'Strings are cool\' d b s ;12gh gh76;';
my $regex = qr/'(.*?(?<!\\))'|\s+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}