#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([+\-*\/]{2,}\d+)|(\([+\*\/])|((?<![\d\)])[+\*\/]\()|(\)[+\-\*\/](?![\d\()]))|((?<![\d\)])(?=[+\*\/]\d+))|(\(\))|(\d+[+\-\*\/](?![\d(]))|((?<![\d\+\-\*\/])\([+\-\*\/])|((?<![\d])[+\-\*\/]\))"
Local $sString = "-(1+2)*10" & @CRLF & _
"" & @CRLF & _
"2+3*(5-6/4)/3+26-122*3/29" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(?>![\\d)])[+\-\*\/]\(" & @CRLF & _
"" & @CRLF & _
"([+\-*\/]{2,}\d+)|(\([+\*\/])|((?>![\\d)])[+\-\*\/]\()|([^\d\)][+\-\*\/]\()|((?<=[+\-\*\/])(0\d+))|(\)[+\-\*\/][^\d\)])|((?<![\d\)])(?=[+\*\/]\d+))|(\(\))" & @CRLF & _
"" & @CRLF & _
"(0*1-0-3)-5/0-4-(3*(-2" & @CRLF & _
"010 + 1" & @CRLF & _
"4-1-" & @CRLF & _
"" & @CRLF & _
"(1-2)*(3-4)" & @CRLF & _
"" & @CRLF & _
"空字符串 🆗" & @CRLF & _
"错误的运算符 🆗" & @CRLF & _
"错误的运算数 🆗" & @CRLF & _
"括号不匹配 ?" & @CRLF & _
"空括号 🆗 " & @CRLF & _
"连续的运算符,例如--5 " & @CRLF & _
"运算符为正数时,其符号+必须省略,例如+2+4定义为非法,而负数时为合法,例如-2+4 前面补零" & @CRLF & _
"程序要能处理表达式中间出现的空格(输入表达式中存在空格为合法情况)" & @CRLF & _
"(后面是运算符 + / * 没数字!" & @CRLF & _
")前面是运算符 + - * / 没数字!" & @CRLF & _
"-)" & @CRLF & _
"(1 -6)-(-1+2)" & @CRLF & _
"010 0 开头的数字" & @CRLF & _
"4-" & @CRLF & _
"" & @CRLF & _
"-(9-1) 允许" & @CRLF & _
"(9-1)- 不允许" & @CRLF & _
"+9+1 不允许" & @CRLF & _
"-9+1 允许" & @CRLF & _
"" & @CRLF & _
"其他不符合表达式书写规则的情况" & @CRLF & _
"(2*2)*2)" & @CRLF & _
"-100*100-(13*4)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")