using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+\-*\/]{2,}\d+)|(\([+\*\/])|((?<![\d\)])[+\*\/]\()|(\)[+\-\*\/](?![\d\()]))|((?<![\d\)])(?=[+\*\/]\d+))|(\(\))|(\d+[+\-\*\/](?![\d(]))|((?<![\d\+\-\*\/])\([+\-\*\/])|((?<![\d])[+\-\*\/]\))";
string input = @"-(1+2)*10
2+3*(5-6/4)/3+26-122*3/29
(?>![\\d)])[+\-\*\/]\(
([+\-*\/]{2,}\d+)|(\([+\*\/])|((?>![\\d)])[+\-\*\/]\()|([^\d\)][+\-\*\/]\()|((?<=[+\-\*\/])(0\d+))|(\)[+\-\*\/][^\d\)])|((?<![\d\)])(?=[+\*\/]\d+))|(\(\))
(0*1-0-3)-5/0-4-(3*(-2
010 + 1
4-1-
(1-2)*(3-4)
空字符串 🆗
错误的运算符 🆗
错误的运算数 🆗
括号不匹配 ?
空括号 🆗
连续的运算符,例如--5
运算符为正数时,其符号+必须省略,例如+2+4定义为非法,而负数时为合法,例如-2+4 前面补零
程序要能处理表达式中间出现的空格(输入表达式中存在空格为合法情况)
(后面是运算符 + / * 没数字!
)前面是运算符 + - * / 没数字!
-)
(1 -6)-(-1+2)
010 0 开头的数字
4-
-(9-1) 允许
(9-1)- 不允许
+9+1 不允许
-9+1 允许
其他不符合表达式书写规则的情况
(2*2)*2)
-100*100-(13*4)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}