#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:skewY?|rotate|matrix)\(([^()]+)\)"
Local $sString = "skew(1deg)" & @CRLF & _
"rotate(3)" & @CRLF & _
"skewY(10deg)" & @CRLF & _
"matrix(0, 0, 0, 0, 0, 0)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")