re = /\b(?:skewY?|rotate|matrix)\(([^()]+)\)/m
str = 'skew(1deg)
rotate(3)
skewY(10deg)
matrix(0, 0, 0, 0, 0, 0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end