#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=From:)[^<]*<(?!\w+@RealDomain\.com>)"
Local $sString = "From: Dude B. CEOName <RealCEO@RealDomain.com> " & @CRLF & _
"From: "Dude B. CEOName" <davidjammyBadPhisherman@gmail.com>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")