$re = '/(?<=From:)[^<]*<(?!\w+@RealDomain\.com>)/m';
$str = 'From: Dude B. CEOName <RealCEO@RealDomain.com>
From: "Dude B. CEOName" <davidjammyBadPhisherman@gmail.com>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);