re = /(?<=From:)[^<]*<(?!\w+@RealDomain\.com>)/m
str = 'From: Dude B. CEOName <RealCEO@RealDomain.com>
From: "Dude B. CEOName" <davidjammyBadPhisherman@gmail.com>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end