using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(፻\S+?\s)(\S+?\s)*?(\S+?)፻";
string substitution = @"$1፻$2፻$3";
string input = @"፻this test works፻
፻this test does not work፻";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}