use strict;
my $str = '፻this test works፻
፻this test does not work፻';
my $regex = qr/(፻\S+?\s)(\S+?\s)*?(\S+?)፻/mp;
my $subst = '$1፻$2፻$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";